Snipe-IT 4.6.0 released! - Read more

Snipe-IT 4.6.0 released!

Thoughts from the Snipe-IT Blog

  • Jul 18 2018 20:23 PM
  • Alison Gianotto

This release fixes a few regression issues from the last few releases related to checkin/checkout email notifications and assets pending acceptance.

We also discovered and fixed an issue with authorization gates that would erroneously display a "checkin" button for license seats that were not actually checked out if a non-admin user had a particular set of granular permissions. Clicking on that "checkin" button would result in a "whoops" error, since it was trying to checkin an asset that wasn't checked out in the first place.

We've added a nicer UI on the asset and license file upload interface as well, which will now show you the names of the files you're uploading.

A new logging table has been added to track login attempts (successful and unsuccessful), although there isn't a UI that exposes that just yet. (Next release.)

And finally, we've cleaned up the Low Inventory email report and the Expiring Assets email report.


IMPORTANT: This will be one of the final releases of Snipe-IT that will work with PHP5. Future versions of Snipe-IT will require PHP 7.1.3 or greater. Please start upgrading your versions of PHP to 7.1.3 to prepare for the next release. There may be a few small bug fix releases before Snipe-IT v5, but you should start preparing now. Seriously.


Added:

  • Added #5859 - added file name/size to file upload UI
  • Added (unofficial) support for PgSQL
  • Added #5842 - added components to location detail view
  • Added login attempt logging
  • Add DB port number to docker configs

Fixed:

  • Fixed issue where you could not check out to a user/location with the same ID as the asset.
  • Fixed regression #5470: Checkin emails not working
  • Fixed regression #5772: Assets requiring acceptance not storing pending acceptance state
  • Fixed #5591 - Removes setting the encryption status on custom field update
  • Fixed activated flag check for login
  • Fixed issue with License gate for non-admins
  • Fixed issue with Location gate for non-admins

Improved:

  • Refactored and cleaned up old code
  • Removed old unused helpers
  • Removed the unused bulk operations for components
  • Nicer email notifications for low inventory report and expiring licenses/assets report

Upgrading

For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

For a full list of changes, see the changelog.


Known Issues

Users running MariaDB 10.2.7 and later may have an issue upgrading or installing, due to a change in the way MariaDB stores null defaults. This issue will be fixed once the open pull request in the Doctrine repo is merged and a new version of Doctrine is released with these fixes. You can read more about that issue here.

After completing the upgrade process below, be sure to clear your browser cookies.


Upgrading from v3

Please see the upgrade instructions here.

Back

Sign-up for a hosted account and get premium support!

Hosted accounts get secure, reliable hosting with top-notch support and preferred priority for feature requests.